View unanswered posts | View active topics It is currently Sun Jul 21, 2019 5:04 pm

Reply to topic  [ 6 posts ] 
 Updating Utilite2 to the official Linaro 
Author Message

Joined: Thu Sep 25, 2014 9:43 am
Posts: 37
Post Updating Utilite2 to the official Linaro
The official Linaro images are much more recent than the ones provided by Compulab (Ubuntu 15.04 with kernel v.3.19 vs. Ubuntu 14.04 with kernel 3.4). And they seem to support directly the Utilite2.

Did anyone have any success updating the OS to the Linaro images?

I made some tries, so far:
- the sudo apt-get update && sudo apt-get dist-upgrade did nothing
- I downloaded and flashed using fastboot the Utilite2 boot image, the Linaro firmware and the Gnome image. The computer booted, but couldn't start GDM (it's marked that the firmware package doesn't include the proprietary drivers)
- I flashed only the boot and Gnome image, leaving the original firmware. This time I could start GDM but it was very slow. That means that the Linaro supports well the Utilite2, but the Compulab drivers don't work well with the new Linaro.

Did anybody get further? Is there any recent firmware package for the Utilite2? It would be great to have an updated OS on our computer!

Fri May 29, 2015 9:10 am

Joined: Mon Mar 02, 2015 9:48 am
Posts: 4
Post Re: Updating Utilite2 to the official Linaro
I have tried several Linaro releases on the different Utilite2's I have lying around that come from different batches of hardware.

The issue you have encountered is probably that you cannot use the binary drivers provided for 3.4 with a newer kernel like the 3.19. This means you're back to software-only rendering. There *is* a possibility, though, to try out the "freedreno" drivers which can be compiled against the 3.19 kernel and should accelerate most if not everything.

My biggest issue is that all these Linaro kernels (3.19 and even the 3.18 before it) seem to have a lock-up issue, where the whole computer just freezes (HDMI goes black, serial console stops working, everything halts). It can occur after only 5 minutes, or after 24 hours or whatnot. It is most probably not related to thermal issues, but I'd have to examine that more thoroughly. This occurs on all my Utilite2's. Also, I have no "eth0" port under 3.19, it must be a PCI probe issue.

Thu Aug 06, 2015 1:32 pm

Joined: Thu Sep 25, 2014 9:43 am
Posts: 37
Post Re: Updating Utilite2 to the official Linaro
Thanks for sharing your experiences. The uncompatible freedreno driver with the new kernel explains the slow display of the official Linaro distro.
Choosing a well-maintained distro like Linaro was a wise choice by Compulab, so it's easier to update the device than the Utilite 1. But it's a pity they don't release the updated firmware images so the users can keep their devices updated with a current kernel and everything without hassles.

Mon Aug 24, 2015 3:39 pm

Joined: Thu Aug 06, 2015 5:18 am
Posts: 4
Post Re: Updating Utilite2 to the official Linaro

I am currently trying to boot a migrated Linaro "vivid" system. I have no problem staying with 3.4 kernel, but can't boot the latest 4.2 one. I tried mixing instructions from Compulab Kernel pages and Linaro official instructions without any success, the Utilite stays on a blue screen when trying to boot the 4.2 kernel.

I was wondering if it was necessary to flash the firmware-qcom-snapdragon-20150916-129.img file in order to boot the new kernel ?


Mon Oct 26, 2015 1:31 pm

Joined: Fri Feb 10, 2012 7:52 am
Posts: 7
Post Re: Updating Utilite2 to the official Linaro
I've been trying to install the linaro debian to the Utilite2, but no success. ... gon/16.02/

There are no instructions how to handle the proprietary firmware for Utilite2. The firmware-qcom-snapdragon-20160224-38.img from linaro is empty.

Linaro kernel doesn't seem to boot, but I can't verify that.

If I try to boot the linaro Debian with old Ubuntu kernel and firmware, it gets stuck before reaching any prompt, but atleast it tries.

And I can't seem to get usb serial to work to see what's going on. I've tried the E1 on and off and the SW3 pressed and not pressed. No serial port from the µusb connector.

Thu Oct 13, 2016 9:38 am

Joined: Fri Feb 10, 2012 7:52 am
Posts: 7
Post Re: Updating Utilite2 to the official Linaro
Now I got the linaro jessie running on utilite2. Here is briefly what I did:

Compiled kernel and made boot.img with abootimg: ... nux_Kernel

The initrd-link is broken, but it seems initrd created with
update-initramfs -c -k 3.4.0-14.10-cm-qs600-3.3-g1c147a2
in "utilite2-trusty" works as well.

in bootimg.cfg

Wrote linaro-jessie-developer-qcom-snapdragon-20160224-38.img to userdata with fastboot: ... gon/16.02/

Booted the utilite2_ubuntu-installer-image_2015-07-30 from SD-card and there chrooted to the linaro in mmcblk0p13 and in the chroot removed systemd and installed sysvinit: ... stallation

Started the system with fastboot boot boot.img

Fri Dec 16, 2016 12:50 pm
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.