View unanswered posts | View active topics It is currently Tue Oct 16, 2018 2:51 pm



Reply to topic  [ 2 posts ] 
 eth0 not working 
Author Message

Joined: Fri May 20, 2016 2:29 pm
Posts: 1
Post eth0 not working
I've tried multiple utilite's, and for whatever reason i cannot get eth0 to work. Im able to ping eth1 and get responses without issue, however eth0 just seems to be completely nonfunctional and i can't figure out why.

ifconfig:
eth0 Link encap:Ethernet HWaddr 00:01:c0:14:f4:23
inet addr:192.168.0.17 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::201:c0ff:fe14:f423/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3139 errors:0 dropped:0 overruns:0 frame:0
TX packets:180 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:420709 (420.7 KB) TX bytes:15812 (15.8 KB)

eth1 Link encap:Ethernet HWaddr 00:01:c0:15:17:61
inet addr:192.168.1.17 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::201:c0ff:fe15:1761/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:323 errors:0 dropped:0 overruns:0 frame:0
TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:20806 (20.8 KB) TX bytes:4833 (4.8 KB)

netstat -r:
Destination Gateway Genmask Flags MSS Window irtt Iface
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
link-local * 255.255.0.0 U 0 0 0 eth0
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
192.168.1.0 * 255.255.255.0 U 0 0 0 eth1

/etc/interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.0.17
netmask 255.255.255.0

auto eth1
iface eth1 inet static
address 192.168.1.17
netmask 255.255.255.0

auto eth2
iface eth2 inet static
address 192.168.2.37
netmask 255.255.255.0
gateway 192.168.2.1


Fri May 20, 2016 2:35 pm
Profile

Joined: Mon Jul 25, 2011 2:35 pm
Posts: 445
Post Re: eth0 not working
Hello VladDracule,

I'd appreciate it if you could follow the procedure:
1) Connect both interfaces to the same LAN.
2) Get them configured using dhcp.
3) Try accessing the device though both interfaces.

Regards,
Valentin.


Wed Jun 01, 2016 4:25 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.