View unanswered posts | View active topics It is currently Tue Sep 25, 2018 8:28 pm



Reply to topic  [ 12 posts ]  Go to page 1, 2  Next
 Utilite Pro: HDMI audio not working 
Author Message

Joined: Sat Jun 21, 2014 10:37 pm
Posts: 11
Post Utilite Pro: HDMI audio not working
I've had a similar issue with my Zotac htpc but it isn't arm. I went through the motions with alsamixer unmuting things. I ran through the pulseaudio mixer settings to no avail. I could normally fix this issue in a few minutes but this one doesn't seem to be a simple issue.

I need all the help I can get ;)


Tue Jul 08, 2014 8:02 pm
Profile

Joined: Sun Nov 24, 2013 9:13 am
Posts: 210
Post Re: Utilite Pro: HDMI audio not working
have you tried the solutions here?
http://www.utilite-computer.com/forum/v ... =71&t=1560


Wed Jul 09, 2014 10:00 am
Profile

Joined: Sat Jun 21, 2014 10:37 pm
Posts: 11
Post Re: Utilite Pro: HDMI audio not working
I haven't installed any new kernels but I saw that post a while back and it didn't work out for me. I'll have to see what my kernel version is.


Wed Jul 09, 2014 6:07 pm
Profile

Joined: Mon Jul 25, 2011 2:35 pm
Posts: 445
Post Re: Utilite Pro: HDMI audio not working
Hi,

I'd appreciate it if you could post the output of these commands:
# dmesg
# udevadm info -a -p /sys/devices/platform/mxc_dvi.0/
# udevadm info -a -p /sys/devices/platform/mxc_hdmi
# aplay -l
# id

Regards,
Valentin.


Thu Jul 10, 2014 8:36 am
Profile

Joined: Sat Jun 21, 2014 10:37 pm
Posts: 11
Post Re: Utilite Pro: HDMI audio not working
Linux version 3.0.35-cm-fx6-5.5 (val@devel) (gcc version 4.5.2 (Sourcery G++ Lite 2011.03-41) ) #721 SMP Sun Mar 23 14:12:17 IST 2014
CPU: ARMv7 Processor [412fc09a] revision 10 (ARMv7), cr=10c53c7d
CPU: VIPT nonaliasing data cache, VIPT aliasing instruction cache
Machine: Compulab CM-FX6
cm_fx6_v4l_setup: cm_fx6_v4l_msize: 134217728
Memory policy: ECC disabled, Data cache writealloc
CPU identified as i.MX6Q, silicon rev 1.2
On node 0 totalpages: 507904
free_area_init_node: node 0, pgdat c0797480, node_mem_map cb800000
DMA zone: 368 pages used for memmap
DMA zone: 0 pages reserved
DMA zone: 46736 pages, LIFO batch:15
Normal zone: 720 pages used for memmap
Normal zone: 91440 pages, LIFO batch:31
HighMem zone: 4544 pages used for memmap
HighMem zone: 364096 pages, LIFO batch:31
PERCPU: Embedded 7 pages/cpu @cce11000 s5280 r8192 d15200 u32768
pcpu-alloc: s5280 r8192 d15200 u32768 alloc=8*4096
pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3
Built 1 zonelists in Zone order, mobility grouping on. Total pages: 502272
Kernel command line: console=ttymxc3,115200 root=/dev/sda2 rw rootwait cm_fx6_v4l_msize=128M vmalloc=256M
PID hash table entries: 4096 (order: 2, 16384 bytes)
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 960MB 1024MB = 1984MB total
Memory: 2006052k/2006052k available, 91100k reserved, 1474560K highmem
Virtual kernel memory layout:
vector : 0xffff0000 - 0xffff1000 ( 4 kB)
fixmap : 0xfff00000 - 0xfffe0000 ( 896 kB)
DMA : 0xf4600000 - 0xffe00000 ( 184 MB)
vmalloc : 0xe2800000 - 0xf2000000 ( 248 MB)
lowmem : 0xc0000000 - 0xe2000000 ( 544 MB)
pkmap : 0xbfe00000 - 0xc0000000 ( 2 MB)
modules : 0xbf000000 - 0xbfe00000 ( 14 MB)
.init : 0xc0008000 - 0xc0044000 ( 240 kB)
.text : 0xc0044000 - 0xc0739dfc (7128 kB)
.data : 0xc073a000 - 0xc0798500 ( 378 kB)
.bss : 0xc0798524 - 0xc0800ac8 ( 418 kB)
Hierarchical RCU implementation.
RCU dyntick-idle grace-period acceleration is enabled.
NR_IRQS:624
MXC GPIO hardware
sched_clock: 32 bits at 3000kHz, resolution 333ns, wraps every 1431655ms
arm_max_freq=1GHz
MXC_Early serial console at MMIO 0x21f0000 (options '115200')
bootconsole [ttymxc3] enabled
Console: colour dummy device 80x30
Calibrating delay loop... 1581.05 BogoMIPS (lpj=7905280)
pid_max: default: 32768 minimum: 301
Security Framework initialized
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
hw perfevents: enabled with ARMv7 Cortex-A9 PMU driver, 7 counters available
CPU1: Booted secondary processor
CPU2: Booted secondary processor
CPU3: Booted secondary processor
Brought up 4 CPUs
SMP: Total of 4 processors activated (6324.22 BogoMIPS).
devtmpfs: initialized
print_constraints: dummy:
NET: Registered protocol family 16
print_constraints: vddpu: 725 <--> 1300 mV at 1150 mV fast normal
print_constraints: vddcore: 725 <--> 1300 mV at 1150 mV fast normal
print_constraints: vddsoc: 725 <--> 1300 mV at 1200 mV fast normal
print_constraints: vdd2p5: 2000 <--> 2775 mV at 2400 mV fast normal
print_constraints: vdd1p1: 800 <--> 1400 mV at 1100 mV fast normal
print_constraints: vdd3p0: 2625 <--> 3400 mV at 3000 mV fast normal
cpu regulator mode:ldo_enable
hw-breakpoint: found 6 breakpoint and 1 watchpoint registers.
hw-breakpoint: 1 breakpoint(s) reserved for watchpoint single-step.
hw-breakpoint: maximum watchpoint size is 4 bytes.
L310 cache controller enabled
l2x0: 16 ways, CACHE_ID 0x410000c7, AUX_CTRL 0x02070000, Cache size: 1048576 B
bio: create slab <bio-0> at 0
mxs-dma mxs-dma-apbh: initialized
print_constraints: ads7846_vcc: 3300 mV
print_constraints: vmmc: 3300 mV
vgaarb: loaded
SCSI subsystem initialized
libata version 3.00 loaded.
spi_imx imx6q-ecspi.0: probed
spi_imx imx6q-ecspi.1: probed
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
Freescale USB OTG Driver loaded, $Revision: 1.55 $
imx-ipuv3 imx-ipuv3.0: IPU DMFC NORMAL mode: 1(0~1), 5B(4,5), 5F(6,7)
imx-ipuv3 imx-ipuv3.1: IPU DMFC NORMAL mode: 1(0~1), 5B(4,5), 5F(6,7)
Advanced Linux Sound Architecture Driver Version 1.0.24.
Bluetooth: Core ver 2.16
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP socket layer initialized
Bluetooth: SCO socket layer initialized
cfg80211: Calling CRDA to update world regulatory domain
Switching to clocksource mxc_timer1
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
UDP hash table entries: 512 (order: 2, 16384 bytes)
UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
NET: Registered protocol family 1
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
PCI: CLS 0 bytes, default 32
_regulator_get: etb supply vcore not found, using dummy regulator
_regulator_get: etm.0 supply vcore not found, using dummy regulator
_regulator_get: etm.1 supply vcore not found, using dummy regulator
_regulator_get: etm.2 supply vcore not found, using dummy regulator
_regulator_get: etm.3 supply vcore not found, using dummy regulator
Static Power Management for Freescale i.MX6
wait mode is enabled for i.MX6
cpaddr = e2880000 suspend_iram_base=e28f0000
PM driver module loaded
IMX usb wakeup probe
the wakeup pdata is 0xe1da3820
add wake up source irq 75
IMX usb wakeup probe
the wakeup pdata is 0xe1da35e0
i.MXC CPU frequency driver
highmem bounce pool size: 64 pages
JFFS2 version 2.2. (NAND) \xffffffc2\xffffffa9 2001-2006 Red Hat, Inc.
msgmni has been set to 1038
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler deadline registered
io scheduler cfq registered (default)
imx-sdma imx-sdma: loaded firmware 1.1
imx-sdma imx-sdma: initialized
Serial: IMX driver
imx-uart.0: ttymxc0 at MMIO 0x2020000 (irq = 58) is a IMX
imx-uart.3: ttymxc3 at MMIO 0x21f0000 (irq = 61) is a IMX
console [ttymxc3] enabled, bootconsole disabled
imx-uart.1: ttymxc1 at MMIO 0x21e8000 (irq = 59) is a IMX
imx-uart.4: ttymxc4 at MMIO 0x21f4000 (irq = 62) is a IMX
brd: module loaded
loop: module loaded
at24 2-0050: 256 byte at24 EEPROM, writable, 16 bytes/write
ahci: SSS flag set, parallel bus scan disabled
ahci ahci.0: AHCI 0001.0300 32 slots 1 ports 3 Gbps 0x1 impl platform mode
ahci ahci.0: flags: ncq sntf stag pm led clo only pmp pio slum part ccc apst
scsi0 : ahci_platform
ata1: SATA max UDMA/133 mmio [mem 0x02200000-0x02200fff] port 0x100 irq 71
m25p80 spi0.0: found sst25vf016b, expected m25p80
m25p80 spi0.0: sst25vf016b (2048 Kbytes)
Creating 3 MTD partitions on "spi_flash":
0x000000000000-0x0000000c0000 : "uboot"
0x0000000c0000-0x000000100000 : "uboot environment"
0x000000100000-0x000000200000 : "reserved"
No NAND device found.
Chip scan failed
GPMI NAND driver registered. (IMX)
vcan: Virtual CAN interface driver
CAN device driver interface
flexcan netdevice driver
flexcan imx6q-flexcan.0: device registered (reg_base=e29b0000, irq=142)
FEC Ethernet Driver
fec_enet_mii_bus: probed
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
fsl-ehci fsl-ehci.0: Freescale On-Chip EHCI Host Controller
fsl-ehci fsl-ehci.0: new USB bus registered, assigned bus number 1
fsl-ehci fsl-ehci.0: irq 75, io base 0x02184000
fsl-ehci fsl-ehci.0: USB 2.0 started, EHCI 1.00
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
add wake up source irq 72
fsl-ehci fsl-ehci.1: Freescale On-Chip EHCI Host Controller
fsl-ehci fsl-ehci.1: new USB bus registered, assigned bus number 2
fsl-ehci fsl-ehci.1: irq 72, io base 0x02184200
fsl-ehci fsl-ehci.1: USB 2.0 started, EHCI 1.00
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 1 port detected
usbcore: registered new interface driver cdc_wdm
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
ARC USBOTG Device Controller driver (1 August 2005)
mousedev: PS/2 mouse device common for all mice
=======snvs_pwrkey_probe() lp_cr 0x0
=======snvs_pwrkey_probe() lp_cr 0x20
input: snvs_power_key as /devices/virtual/input/input0
i.MX6 powerkey probe
i2c-core: driver [isl29023] using legacy suspend method
i2c-core: driver [isl29023] using legacy resume method
i2c /dev entries driver
at24 3-0050: 256 byte at24 EEPROM, writable, 16 bytes/write
CM-FX6: Detected SB-FX6m (Utilite) base board
rtc-em3027 3-0056: rtc core: registered rtc-em3027 as rtc0
iMX6 PCIe PCIe RC mode imx_pcie_pltfm_probe entering.
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata1.00: ATA-9: SanDisk SSD U110 32GB, U221000, max UDMA/133
ata1.00: 62533296 sectors, multi 1: LBA48 NCQ (depth 31/32)
ata1.00: configured for UDMA/133
scsi 0:0:0:0: Direct-Access ATA SanDisk SSD U110 U221 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 62533296 512-byte logical blocks: (32.0 GB/29.8 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sda: sda1 sda2
sd 0:0:0:0: [sda] Attached SCSI disk
PCIE: imx_pcie_pltfm_probe start link up.
IMX PCIe port: link up.
pci 0000:00:00.0: [16c3:abcd] type 1 class 0x000604
pci 0000:00:00.0: reg 10: [mem 0x00000000-0x000fffff 64bit pref]
pci 0000:00:00.0: reg 38: [mem 0x00000000-0x0000ffff pref]
pci 0000:00:00.0: supports D1
pci 0000:00:00.0: PME# supported from D0 D1 D3hot D3cold
pci 0000:00:00.0: PME# disabled
PCI: bus0: Fast back to back transfers disabled
pci 0000:01:00.0: [8086:1539] type 0 class 0x000200
pci 0000:01:00.0: reg 10: [mem 0x00000000-0x0001ffff]
pci 0000:01:00.0: reg 18: [io 0x0000-0x001f]
pci 0000:01:00.0: reg 1c: [mem 0x00000000-0x00003fff]
pci 0000:01:00.0: PME# supported from D0 D3hot D3cold
pci 0000:01:00.0: PME# disabled
PCI: bus1: Fast back to back transfers disabled
PCI: Device 0000:00:00.0 not available because of resource collisions
pcieport: probe of 0000:00:00.0 failed with error -22
pci 0000:00:00.0: BAR 0: assigned [mem 0x01000000-0x010fffff 64bit pref]
pci 0000:00:00.0: BAR 0: set to [mem 0x01000000-0x010fffff 64bit pref] (PCI address [0x1000000-0x10fffff])
pci 0000:00:00.0: BAR 8: assigned [mem 0x01100000-0x011fffff]
pci 0000:00:00.0: BAR 6: assigned [mem 0x01200000-0x0120ffff pref]
pci 0000:00:00.0: BAR 7: assigned [io 0x1e00000-0x1e00fff]
pci 0000:01:00.0: BAR 0: assigned [mem 0x01100000-0x0111ffff]
pci 0000:01:00.0: BAR 0: set to [mem 0x01100000-0x0111ffff] (PCI address [0x1100000-0x111ffff])
pci 0000:01:00.0: BAR 3: assigned [mem 0x01120000-0x01123fff]
pci 0000:01:00.0: BAR 3: set to [mem 0x01120000-0x01123fff] (PCI address [0x1120000-0x1123fff])
pci 0000:01:00.0: BAR 2: assigned [io 0x1e00000-0x1e0001f]
usb 2-1: new high speed USB device number 2 using fsl-ehci
pci 0000:01:00.0: BAR 2: set to [io 0x1e00000-0x1e0001f] (PCI address [0x1e00000-0x1e0001f])
pci 0000:00:00.0: PCI bridge to [bus 01-01]
pci 0000:00:00.0: bridge window [io 0x1e00000-0x1e00fff]
pci 0000:00:00.0: bridge window [mem 0x01100000-0x011fffff]
pci 0000:00:00.0: bridge window [mem pref disabled]
i2c i2c-0: Added multiplexed i2c bus 3
i2c i2c-0: Added multiplexed i2c bus 4
gpio-i2cmux gpio-i2cmux: 2 port mux on imx-i2c adapter
Linux media interface: v0.10
lirc_dev: IR Remote Control driver registered, major 251
IR NEC protocol handler initialized
IR RC5(x) protocol handler initialized
IR RC6 protocol handler initialized
IR JVC protocol handler initialized
IR Sony protocol handler initialized
IR RC5 (streamzap) protocol handler initialized
IR LIRC bridge handler initialized
Linux video capture interface: v2.00
imx2-wdt imx2-wdt.0: IMX2+ Watchdog Timer enabled. timeout=60s (nowayout=1)
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
mmc0: SDHCI controller on platform [sdhci-esdhc-imx.0] using DMA
mmc1: SDHCI controller on platform [sdhci-esdhc-imx.2] using DMA
VPU initialized
mxc_asrc registered
Thermal calibration data is 0x56d4cf69
Thermal sensor with ratio = 179
hub 2-1:1.0: USB hub found
Anatop Thermal registered as thermal_zone0
hub 2-1:1.0: 4 ports detected
anatop_thermal_probe: default cooling device is cpufreq!
Registered led device: cm_fx6:green
mmc0: new high speed SDIO card at address 0001
caam caam.0: device ID = 0x0a16010000000000
caam caam.0: job rings = 2, qi = 0
alg: No test for authenc(hmac(md5),cbc(aes)) (authenc-hmac-md5-cbc-aes-caam)
caam caam.0: authenc-hmac-md5-cbc-aes-caam
alg: No test for authenc(hmac(sha1),cbc(aes)) (authenc-hmac-sha1-cbc-aes-caam)
caam caam.0: authenc-hmac-sha1-cbc-aes-caam
alg: No test for authenc(hmac(sha224),cbc(aes)) (authenc-hmac-sha224-cbc-aes-caam)
caam caam.0: authenc-hmac-sha224-cbc-aes-caam
alg: No test for authenc(hmac(sha256),cbc(aes)) (authenc-hmac-sha256-cbc-aes-caam)
caam caam.0: authenc-hmac-sha256-cbc-aes-caam
alg: No test for authenc(hmac(md5),cbc(des3_ede)) (authenc-hmac-md5-cbc-des3_ede-caam)
caam caam.0: authenc-hmac-md5-cbc-des3_ede-caam
alg: No test for authenc(hmac(sha1),cbc(des3_ede)) (authenc-hmac-sha1-cbc-des3_ede-caam)
caam caam.0: authenc-hmac-sha1-cbc-des3_ede-caam
alg: No test for authenc(hmac(sha224),cbc(des3_ede)) (authenc-hmac-sha224-cbc-des3_ede-caam)
caam caam.0: authenc-hmac-sha224-cbc-des3_ede-caam
alg: No test for authenc(hmac(sha256),cbc(des3_ede)) (authenc-hmac-sha256-cbc-des3_ede-caam)
caam caam.0: authenc-hmac-sha256-cbc-des3_ede-caam
alg: No test for authenc(hmac(md5),cbc(des)) (authenc-hmac-md5-cbc-des-caam)
caam caam.0: authenc-hmac-md5-cbc-des-caam
alg: No test for authenc(hmac(sha1),cbc(des)) (authenc-hmac-sha1-cbc-des-caam)
caam caam.0: authenc-hmac-sha1-cbc-des-caam
alg: No test for authenc(hmac(sha224),cbc(des)) (authenc-hmac-sha224-cbc-des-caam)
caam caam.0: authenc-hmac-sha224-cbc-des-caam
alg: No test for authenc(hmac(sha256),cbc(des)) (authenc-hmac-sha256-cbc-des-caam)
caam caam.0: authenc-hmac-sha256-cbc-des-caam
usb 2-1.3: new full speed USB device number 3 using fsl-ehci
caam caam.0: cbc-aes-caam
caam caam.0: cbc-3des-caam
caam caam.0: cbc-des-caam
USB Host suspend begins
will suspend roothub and its children
ehci_fsl_bus_suspend begins, DR
ehci_fsl_bus_suspend ends, DR
host suspend ends
platform caam_jr.0: registering rng-caam
input: Logitech USB Receiver as /devices/platform/fsl-ehci.1/usb2/2-1/2-1.3/2-1.3:1.0/input/input1
generic-usb 0003:046D:C52B.0001: input,hidraw0: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-fsl-ehci.1-1.3/input0
input: Logitech USB Receiver as /devices/platform/fsl-ehci.1/usb2/2-1/2-1.3/2-1.3:1.1/input/input2
generic-usb 0003:046D:C52B.0002: input,hidraw1: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-fsl-ehci.1-1.3/input1
generic-usb 0003:046D:C52B.0003: hidraw2: USB HID v1.11 Device [Logitech USB Receiver] on usb-fsl-ehci.1-1.3/input2
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
usbcore: registered new interface driver snd-usb-audio
mxc_spdif mxc_spdif.0: MXC SPDIF Audio
_regulator_get: 2-001a supply AVDD not found, using dummy regulator
_regulator_get: 2-001a supply HPVDD not found, using dummy regulator
_regulator_get: 2-001a supply DCVDD not found, using dummy regulator
_regulator_get: 2-001a supply DBVDD not found, using dummy regulator
imx_wm8731_init: success
asoc: wm8731-hifi <-> imx-ssi.1 mapping ok
asoc: mxc-spdif <-> imx-spdif-dai.0 mapping ok
ALSA device list:
#0: wm8731-audio
#1: imx-spdif
NET: Registered protocol family 26
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP cubic registered
NET: Registered protocol family 17
can: controller area network core (rev 20090105 abi 8)
NET: Registered protocol family 29
can: raw protocol (rev 20090105)
can: broadcast manager protocol (rev 20090105 t)
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM ver 1.11
Bluetooth: BNEP (Ethernet Emulation) ver 1.3
Bluetooth: BNEP filters: protocol multicast
Bluetooth: HIDP (Human Interface Emulation) ver 1.2
lib80211: common routines for IEEE802.11 drivers
lib80211_crypt: registered algorithm 'NULL'
lib80211_crypt: registered algorithm 'WEP'
lib80211_crypt: registered algorithm 'CCMP'
lib80211_crypt: registered algorithm 'TKIP'
HDMI CEC initialized
mxc_vdoa mxc_vdoa: i.MX Video Data Order Adapter(VDOA) driver probed
mxc_sdc_fb mxc_sdc_fb.0: register mxc display driver hdmi
mxc_hdmi mxc_hdmi: Detected HDMI controller 0x13:0xa:0xa0:0xc1
imx-ipuv3 imx-ipuv3.0: IPU DMFC DP HIGH RESOLUTION: 1(0,1), 5B(2~5), 5F(6,7)
Console: switching to colour frame buffer device 240x67
mxc_sdc_fb mxc_sdc_fb.1: register mxc display driver dvi
_regulator_get: get() with no identifier
mxc_hdmi_soc mxc_hdmi_soc.0: MXC HDMI Audio
asoc: mxc-hdmi-soc <-> imx-hdmi-soc-dai.0 mapping ok
mxc_v4l2_output mxc_v4l2_output.0: V4L2 device registered as video16
mxc_v4l2_output mxc_v4l2_output.0: V4L2 device registered as video17
mxc_v4l2_output mxc_v4l2_output.0: V4L2 device registered as video18
VFP support v0.3: implementor 41 architecture 3 part 30 variant 9 rev 4
Bus freq driver module loaded
Bus freq driver Enabled
mxc_dvfs_core_probe
DVFS driver module loaded
regulator_init_complete: ads7846_vcc: incomplete constraints, leaving on
rtc-em3027 3-0056: setting system clock to 2014-07-10 03:31:01 UTC (1404963061)
EXT3-fs (sda2): error: couldn't mount because of unsupported optional features (240)
EXT2-fs (sda2): error: couldn't mount because of unsupported optional features (244)
EXT4-fs (sda2): ext4_orphan_cleanup: deleting unreferenced inode 2046
EXT4-fs (sda2): 1 orphan inode deleted
EXT4-fs (sda2): recovery complete
EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
VFS: Mounted root (ext4 filesystem) on device 8:2.
devtmpfs: mounted
Freeing init memory: 240K
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
udevd[1453]: starting version 175
udevd[1779]: renamed network interface eth0 to eth2
Intel(R) Gigabit Ethernet Network Driver - version 4.1.2
Copyright (c) 2007-2012 Intel Corporation.
PCI: enabling device 0000:01:00.0 (0140 -> 0142)
igb: 0000:01:00.0: igb_check_options: VMDq option is not supported.
igb 0000:01:00.0: Failed to initialize MSI-X interrupts. Falling back to MSI interrupts.
igb 0000:01:00.0: Failed to initialize MSI interrupts. Falling back to legacy interrupts.
ads7846 spi0.1: touchscreen, irq 303
input: ADS7846 Touchscreen as /devices/platform/imx6q-ecspi.0/spi_master/spi0/spi0.1/input/input3
igb 0000:01:00.0: Intel(R) Gigabit Ethernet Network Connection
igb 0000:01:00.0: eth0: (PCIe:2.5GT/s:Width x1)
igb 0000:01:00.0: eth0: MAC: 00:01:c0:15:28:4b
igb 0000:01:00.0: eth0: PBA No: FFFFFF-0FF
igb 0000:01:00.0: LRO is disabled
igb 0000:01:00.0: Using legacy interrupts. 1 rx queue(s), 1 tx queue(s)
udevd[1777]: renamed network interface eth0 to eth3
init: failsafe main process (2291) killed by TERM signal
mwifiex_sdio mmc0:0001:1: WLAN FW is active
mwifiex_sdio mmc0:0001:1: info: successfully registered wiphy device
mwifiex_sdio mmc0:0001:1: info: mlan0: Marvell 802.11 Adapter
mwifiex_sdio mmc0:0001:1: driver_version = mwifiex 1.0 (14.57.5.p44)
Bluetooth: vendor=0x2df, device=0x911a, class=255, fn=2
init: alsa-restore main process (2898) terminated with status 99
init: gdm main process (2942) killed by TERM signal
vgaarb: this pci device is not a vga device
vgaarb: this pci device is not a vga device
[drm] Initialized drm 1.1.0 20060810
[drm] Initialized vivante 1.0.0 20120216 on minor 0
init: plymouth-stop pre-start process (3061) terminated with status 1
eth2: Freescale FEC PHY driver [Generic PHY] (mii_bus:phy_addr=1:00, irq=-1)
ieee80211 phy0: info: ignoring the timeout value for IEEE power save
ieee80211 phy0: info: received scan request on mlan0
fuse init (API version 7.16)
igb: eth3 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
ieee80211 phy0: info: ignoring the timeout value for IEEE power save
ehci_fsl_bus_resume begins, DR
warning: process `colord' used the deprecated sysctl system call with 8.1.2.
mwifiex_sdio mmc0:0001:1: info: mwifiex_cfg80211_results: sending scan results
ieee80211 phy0: info: received scan request on mlan0
mxc_hdmi mxc_hdmi: Read EDID again
mxc_hdmi mxc_hdmi: No modes read from edid
mxc_hdmi mxc_hdmi: create default modelist
mwifiex_sdio mmc0:0001:1: info: mwifiex_cfg80211_results: sending scan results
ieee80211 phy0: info: received scan request on mlan0
mwifiex_sdio mmc0:0001:1: info: mwifiex_cfg80211_results: sending scan results
ieee80211 phy0: info: received scan request on mlan0
mwifiex_sdio mmc0:0001:1: info: mwifiex_cfg80211_results: sending scan results
ieee80211 phy0: info: received scan request on mlan0
mwifiex_sdio mmc0:0001:1: info: mwifiex_cfg80211_results: sending scan results
ieee80211 phy0: info: received scan request on mlan0
mwifiex_sdio mmc0:0001:1: info: mwifiex_cfg80211_results: sending scan results
ieee80211 phy0: info: received scan request on mlan0
mwifiex_sdio mmc0:0001:1: info: mwifiex_cfg80211_results: sending scan results
ieee80211 phy0: info: received scan request on mlan0
mwifiex_sdio mmc0:0001:1: info: mwifiex_cfg80211_results: sending scan results

root@utilite-desktop:/home/utilite# udevadm info -a -p /sys/devices/platform/mxc_dvi.0/

Udevadm info starts with the device specified by the devpath and then
walks up the chain of parent devices. It prints for every device
found, all possible attributes in the udev rules key format.
A rule to match, can be composed by the attributes of the device
and the attributes from one single parent device.

looking at device '/devices/platform/mxc_dvi.0':
KERNEL=="mxc_dvi.0"
SUBSYSTEM=="platform"
DRIVER==""
ATTR{fb_name}=="DISP3 BG"
ATTR{cable_state}=="plugout"

looking at parent device '/devices/platform':
KERNELS=="platform"
SUBSYSTEMS==""
DRIVERS==""

root@utilite-desktop:/home/utilite# udevadm info -a -p /sys/devices/platform/mxc_hdmi

Udevadm info starts with the device specified by the devpath and then
walks up the chain of parent devices. It prints for every device
found, all possible attributes in the udev rules key format.
A rule to match, can be composed by the attributes of the device
and the attributes from one single parent device.

looking at device '/devices/platform/mxc_hdmi':
KERNEL=="mxc_hdmi"
SUBSYSTEM=="platform"
DRIVER=="mxc_hdmi"
ATTR{fb_name}=="DISP3 BG - DI1"
ATTR{cable_state}=="plugin"
ATTR{rgb_out_enable}=="RGB out"

looking at parent device '/devices/platform':
KERNELS=="platform"
SUBSYSTEMS==""
DRIVERS==""

root@utilite-desktop:/home/utilite# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: wm8731audio [wm8731-audio], device 0: HiFi wm8731-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: imxspdif [imx-spdif], device 0: IMX SPDIF mxc-spdif-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: imxhdmisoc [imx-hdmi-soc], device 0: IMX HDMI TX mxc-hdmi-soc-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
root@utilite-desktop:/home/utilite# ^C
root@utilite-desktop:/home/utilite# id
uid=0(root) gid=0(root) groups=0(root)


Fri Jul 11, 2014 3:39 am
Profile

Joined: Mon Jul 25, 2011 2:35 pm
Posts: 445
Post Re: Utilite Pro: HDMI audio not working
Hi,

1)
Quote:
mxc_hdmi mxc_hdmi: Read EDID again
mxc_hdmi mxc_hdmi: No modes read from edid
mxc_hdmi mxc_hdmi: create default modelist


These strings look very suspicious.
What cable has been used and what monitor?

2)
What user do you get logged in with X?
Please switch to the user you get logged in with X and issue:
# id
# aplay -l
# aplay -vD hw:2,0 sample.wav
# mplayer -ao alsa:device=hw=2.0 sample.mp3

I'd appreciate it if you could try this out using "root" account as well.
# aplay -vD hw:2,0 sample.wav
# mplayer -ao alsa:device=hw=2.0 sample.mp3

Let me know about results.

NOTE:
Make sure that the hdmi device you make use of is initialized (X is running and HDMI is the output ).

Regards,
Valentin.


Last edited by valentin on Sun Jul 13, 2014 8:05 am, edited 1 time in total.



Sun Jul 13, 2014 7:02 am
Profile

Joined: Sat Jun 21, 2014 10:37 pm
Posts: 11
Post Re: Utilite Pro: HDMI audio not working
Regular HDMI cable and Panasonic HDTV


Sun Jul 13, 2014 7:09 am
Profile

Joined: Mon Jul 25, 2011 2:35 pm
Posts: 445
Post Re: Utilite Pro: HDMI audio not working
Hi,

Did you have a chance to play a sample file as "root" and as a non-root user?

Regards,
Valentin.


Thu Jul 17, 2014 9:11 am
Profile

Joined: Sat Jun 21, 2014 10:37 pm
Posts: 11
Post Re: Utilite Pro: HDMI audio not working
I didn't see that you edited your reply. I haven't tried it but I'll check it.

I'm still using the default user utilite.

I get the error Invalid value for card
audio open_error: No such device
for the root account I get the same.


Thu Jul 17, 2014 3:10 pm
Profile

Joined: Mon Jul 25, 2011 2:35 pm
Posts: 445
Post Re: Utilite Pro: HDMI audio not working
Hi,

Quote:
audio open_error: No such device


Means that an incorrect card value has been passed as a parameter.
Make sure you have specified an existed card.

Could you please make use of this "aplay.sh" script to select the sound output?

1) Download it to the Utilite:
# wget http://utilite-computer.com/download/utilite/tools/aplay.sh
2) Set executable permission:
# chmod a+x aplay.sh
3) Issue the script with the sample.wav:
# aplay.sh sample.wav
you will have this output:
1) sysdefault:CARD=wm8731audio
2) sysdefault:CARD=imxspdif
3) sysdefault:CARD=imxhdmisoc
4) <<
Selected an output device : 3

Select '3' and press 'Enter'.

Let me know about the results.

Regards,
Valentin.


Sun Jul 20, 2014 12:27 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 12 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.